QuickBooks Online supports these browsers…except when it doesn’t

Oh, you support Safari 5.0.1 do you?

I guess not.

Maybe the reason why QuickBooks Online for the Mac is still in beta¬†after almost 1 1/2 years since the “beta” launched is they are still trying to¬†figure out how to get the Safari version number logic correct?

And yes, it’s this kind of ineptitude that makes me fear for Mint’s future.

Trackbacks

  1. […] Oh really, you support Safari 5.0.1 do you? Then how do you explain THIS!?Source:http://picchore.com/wtf/quickbooks-mac-bet/ var stLink = jQuery('a:last')[0]; stLink.href = 'javascript:void(0)'; SHARETHIS_post = […]

Speak Your Mind

*